
 
INTRO TO EDITING MESHES IN BLENDER – EDGES 

By Mr. D at Delta 3D 
 

  Open up Blender and if there is not one already create or switch a Window to ‘3D 
View’.  Then if the Window is not Maximized press ‘Ctrl UpArrow’, and set your 
Mode List to ‘Edit Mode’. 

 
(If continuing from Intro-Vertices) 

  On to ‘Edges’ so let’s first clear things up a bit, either go to your User Preferences Bar 
and do a ‘File >New’ and answer Ok? > Erase All (if your preferences are at default you 
will go back to a multi window view and most likely you are in ‘Object Mode’ for your 
‘3D View Window’.  Not to worry, simply highlight your ‘3DView Window’ and press 
‘Ctrl UpArrow’ to maximize.  Now move to the Mode List and switch from Object to 
Edit, or use the ‘Tab’ key shortcut). 
 
  Also you can try going back to ‘Object Mode’ from the Mode List, then select your 
Cube and hit the ‘Delete’ button and Ok? >Erase Selected Object(s).  Now you’ll need a 
new Cube to work with, and to do that go to User Preferences Bar then Add >Mesh 
>Cube.  But remember that the Cube is created at the location of your Marking Cursor. 
(Also after creation try pressing ‘n’ to get the ‘Transform Properties PopUp’, and use it to 
set your XYZ location to 0,0,0.  Most likely you’ll have to zero out the Cube’s rotation 
numbers as well). 
 
  Now toggle between ‘Object’ and ‘Edit’ modes using the ‘Tab’ key just to get use to it, 
but end up in ‘Edit’ Mode. 
 
MAKE FACE/EDGE 
  From the ‘Mesh’ hotspot bring up your list of actions, and highlight ‘Edges’ on it the 
top action is ‘Make Face/Edge’ or ‘f’.  This will take a moment to explain.  And edge 
connects two vertices; a face is three edges and three vertices.  So to make a new Edge or 
Face you need to find a) 2 Vertices that do not share and Edge to make a new edge.  b) 
for a face three Vertices that have no more than 2 edges.  Having a third edge would 
make this a face already. 
 
  Confusing but follow along to help understand better. 
  First we need to go back to ‘Vertices’ Mode and make and extra Vertex.  So in ‘Edit 
Mode’ click the Vertices Icon and hit ‘a’ if need be to unselect all, plus be in ‘Translate’ 
the Red Triangle Icon.  Now click select a Vertex and using Menu (Mesh >Vertices 
>Split), or Marker (hold down mouse button in open area) Edit >Vertices >Split; or 
simple use the ‘y’ shortcut to split the vertex. 
  Remember not to move your mouse until the Ok? >Split pop up appears under its cursor 
for you to click, then click.  Nothing appears to happen, but a new vertex was created at 
the same place as the selected one, and it is now the selected vertex.  Move your mouse to 
the ‘Translate’ axis a click and holding drag the new vertex away from your cube. 
 



  Now to make and edge, so release 
the mouse button (your new vertex 
is still yellow indicating it is 
selected), and holding down the 
‘Shift’ key click select the original 
vertex. 
Here’s a tricky place, as Blender 
does not offer ‘Make Face/Edge’ 
from the ‘Vertices’ mode.  You 
can’t switch back into ‘Edges’ 
Mode because your vertices will n
longer be selected.  So you have to 
remember the shortcut is the ‘f’ 
key 

o 

 
 
 
 

 
Could you do that from edges, at first we 
needed to create the extra vertex simply 
because our Cube’s a nice solid piece of 
geometry.  But once we had the extra edge 
from ‘Vertices’ Mode you could have 
picked two edges to make the face from 
within ‘Edges’ Mode. 
 
 
 
 
 
 

 
  How does this help in modeling? 
  The above portion may seem a bit confusing, mainly because we started out with a 
simple object like a cube.  When building a mesh model normally it will in tell a greater 
degree of complexity.  There will be far more faces-edges-vertices to have to deal with. 
You’ll be building and cutting up various meshes, or joining one or more that do not 
always match up. So adding faces and edges becomes more important then. 
 
  Below a little example of how it might also be used. 
 
  Start off by doing a File >New, and get yourself a new cube.  Now add a second cube by 
doing Add >Mesh >Cube, then checking to make sure your ‘3D View’ is on ‘Object’ 
Mode move the new Cube a bit away from the first. 



  Now we’ll turn these two objects into one by Joining them together.  Still in ‘Object’ 
Mode select one Cube then ‘Shift’ click select the other.  Now join them through Menu 
of Object >Join Objects or ‘Ctrl j’ shortcut, or use the Tool Box menu. 
  We’ll say I’m making a castle for an adventure game and these cubes are my two 
towers.  However I want walls running between them.  Now I could duplicate faces then 
do some vertex welding.  Or I could extrude edges, but there is a simpler way. 
  
  Go into ‘Edge’ Mode and pick the two opposite inner edges of the Cubes and hit the ‘f’  
Key to make a wall (since you are in Edge Mode you could use the Menu here).  Now the 
other two edges and hit ‘f’ again to make the other wall. 

Nice, quick and simple, plus no need to worry about attaching up a bunch of vertices 
 
  So how did Blender know to make a face/quad here as the two edges did not touch?   
Actually in this case Blender is considering that each edge has two vertices for a total of 
four, which is what you need to make a quad.  Could I have gone in to ‘Vertices’ Mode, 
then picked each of the four vertices?  Yes, but its quicker to pick 2 edges than 4 
Vertices. 
  And remember you have to be in an area where a face or edge does not already exist.  
Try this out by picking to edges on opposite sides of a quad and read the message that 
shows up. 
 
 
BEVEL ‘W Alt2’ 
  In using ‘Bevel’ Blender tries to round over and objects edges to give a more smooth 
appearance.  Understand the regular bevel command works on the whole object, not just 
selected edges.  The command is listed under the ‘Edges’ sub-object category because the 
action is being carried out on ‘Edges’.  There is suppose to be a Python script that can do 
this, but using Blender v2.42 and Python v2.4.4 I kept getting ‘Script Error’ message 
every time I tried to run the Bevel Center script I found.  Most likely indicating there are 
version problems with the script, unknown if on Blender side or Python.  
 
  Go to Meshes >Edges >Bevel, a pop up appears under your cursor called ‘Recursion: 
(#) and OK.  The (#) you use to change the ‘Recursion’ value by click-hold on the 
number and slide your mouse back and forth, or click on the word ‘Recursion’ to open 
up for numeric input by keyboard. 
  Recursion deals with the number of step your bevel command does between two edges 
to round them over.  The higher the recursions number the higher the number of steps, 



and the smoother the round over.  But remember the more recursions the more faces 
added. 

Note: 
  When you fist click ‘Bevel’ you’ll notice your mesh becomes filled with yellow lines.  
These are tool/gizmo representation of your mesh’s faces, and what you are looking for 
here is the opening of space between faces as you move your mouse.  This space is where 
the Beveling will occur, and the smaller sized faces what the new size of the original 
faces will be.  The first Cube in the image created Recursions: 3. 
 
  Also about the keyboard shortcut ‘W Alt2’, so first you hit ‘W’ and a list called 
Specials pops up. Then you press ‘Alt2’ to get Bevel.  Find in practice it is easier to hit 
‘W’ then simply pick Bevel from the list using your mouse. 
 
 
LOOP SUBDIVIDE ‘Ctrl r’ 
  This tool is similar to a slicing plane in 3dsMax and Maya.  But here you can not slice 
selected edges or faces; instead the plane slices the entire object. 
  Simply be in ‘Edge’ Mode and go Mesh >Vertices >Loop Subdivide or ‘Ctrl r’.  A 
purplish loop appears denoting the cutting plane within your object.  Move your mouse 
over the faces of your mesh to re-orient the ‘Loop’ angle to the faces.  When you get the 
angle you like click once and the ‘Loop’ turns yellow and the edge to which the ‘Loop’ 
is aligning itself turns green.  Moving your mouse slides the ‘Loop’ along this edge as a 

  Beveled Cube use to better show how all edges are cut. 

guiding rail.  Next position the ‘Loop’ to your liking in the mesh. 

lick again and the green edge disappears, however you still see a yellow ‘Loop’ line, 
but actually these are the newly created edges you have just made selected.  Hit ‘a’ to 
deselect all to view your mesh and you’ll see the new edges there. 

 
C



 
KNIFE SUBDIVIDE ‘Shift k’   
   Used to subdivide edges, also Blender does not have a command similar to ‘Cut 

ace(s)’ found in other 3D packages.  In Blender if you’re cutting a face, you are actually 

ut ‘Shift k’ make sure your mouse is away from other edges before 
he 

ne.  Clicking ‘Exact Line’ changes your 
ursor to the cutting/scalpel icon, now move it to where you 

ou 

nd forth over the selected line, but the ‘Exact Line’ only 
e 

 MIDPOINTS:  You cut the same way, but no matter                
here you make your cut Blender splits the ‘Edge’ at its mi

 

 
 
 

F
cutting two edges. 
  In ‘Edges’ sub-mode select an edge you wish to cut.  Do a Mesh >Edges >Knife 
Subdivide, and a popup called ‘Cut Type’ appears under your cursor.  If you are using 
the keyboard shortc
pressing them.  Find sometimes your edge selection suddenly goes to an edge that t
mouse is over. 
 
  EXACT LINE:  This means cut the ‘Edge’ exactly where I 
create my cut li
c
would like the cut, you do not have to be on the line, click 
and drag a cutting line over the point on the edge where y
wish to subdivide it.  Once you go over the line release the 
mouse button, but DO NOT CLICK AGAIN, instead press 
the ‘Enter’ key to cut the edge. 
 
  You could continue drawing out the line to cross other 
vertices, but only the one is selected.  You could also go back 
a
makes a cut over the first place the cutting line crossed th
selected Edge. 
 
 
 
  
w dpoint. 

 
   
 
 
 
 
 
 
 
 

 
 



MULTICUTS:  When you choose ‘Multicuts’, a pop up appears under your cursor 
sking ‘Number of cuts (#)  OK’.  Same as before hold and slide to change the number of 
uts, or click on words to keyboard enter.  Hit OK and draw your line like before, you 

d 

e 

to 

 SUBDIVIDE AS

a
c
actually need only cross the edge once by click dragging out your ‘Cutting Line’ an
hitting ‘Enter’.  As with ‘Midpoints’  Blender carries out a proportional dividing of the 
edge.  So a number of two cuts produces 3 even sized edge segments, 3cuts makes 4. 
In the image I drew a 
looping ‘Cut Line’ back 
over the ‘Edge’.   
  This is just to show 
how my line is at th
far end of the ‘Edge’. 
You really only need 
draw across the line 
once, that is because 
Blender calculates out 
the cut points on the 
edge. 
 
 
KNIFE  FACE CUTTING TOOL 
 
  In the above example I used ‘Knife Subdivide’ to cut just a single edge.  But the tool 

 edges on the same face dividing the 
face as you might use a Face Cut 

 
oosing 

a 

can also be used to cut multiple edges at once or two

in 3dsMax or Maya. 
  Pick two edges on your Cube 
opposite one another, and then
do a ‘Knife Subdivide’ ch
the type you want. You just cut 
face, but remember Blender 
thinks you subdivided 2 edges.  
Try picking and cutting more 
Edges. 

TIP:  When Blender cut the Edges it has to create new ed
Blender then displays these new edges, but things after a
  To help clean things up a bit switch into ‘Faces’ Mode ‘a’ to select all faces.  

 
 
 
 
 

ges running from the cut point.  
 few cuts get kind of busy. 
and use 

Now Mesh >Faces >Convert Triangles to Quads or ‘Alt j’ should help clean up some. 
 
 
 



  Remember Blender currently does not handle N-gons, so even though that front face is 
ice and co-planar it still has to do a quad and tri combination.   n

 
SUBDIVIDE  ‘w 1’ 
  Sub-dividing is another way to go about cutting up edges, but here it is always 

roportional meaning a mathematical division (1/2, 1/3, 1/4…) 
Take Note:

p
  To the left are Sub-divide 

Hot 
r Menu – Mesh you get 

List. 
  Box and Menu show most common actions

gs 
ist and 1 is the option’s position on that list.  Seeing the number on the shortcut 

d 

action lists, notice how though the ‘
Box’ or Edit Heade
3 choices.  But when used the keyboard 
shortcut ‘w’, you get the added choice of 
Subdivide Multi, and Subdivide Fractal 
becomes Subdivide Multi Fractal. 
  In Blender sometimes fewer actions may 
ple with ‘w’ Specials List or ‘m’ Merge show in the Hot Box or Menu Bar, for exam

 used, but more types of actions maybe 
available.  Especially if you see a Keyboard shortcut listed like ‘w 1’, meaning w brin
up a l
tends to mean a long list, and when you see this it is best to hit the first letter keyboar
shortcut to see the whole list. 
 
  Subdivide: ‘w 1’ simply cuts an Edge in half, if a single Edge the Face(s) associated 
with that Edge will be divided up into Triangular face.  If Opposite Edges sharing a Face 
re subdivided 2Quads are produced, but only on that face. 

 
a
  If two Edges share a Face, and also share Vertices in common, Blender cuts the Edges
but also makes additional cuts/Triangles as needed to prevent N-gons from being created.  
 
 
 
 
 
 
 
 
 
 
   
  Subdivide Multi: ‘w 2’ specify evenly 
spaced series of cut on selected edge(s) 

ough pop up.  Again notice where needed thr
Blender cuts extra geometry to prevent N-
gons.   
(3 sides = Tri, 4 sides = Quad, 5 sides plus = 
N-gon) 
 



  Subdivide Multi Fractal: ‘w 3’ 
  First part is the same as Subdivide 

e.  But it 

etex 
. 

 
 

 damage.  Picking a num
ppear damaged. 

Multi, where a popup asks for 
number of Cuts to be mad
then wants a Rand(om) factor 
which randomly modifies the v
position of the of the results
  Usefulness:  You have a model of
a car that you quickly want to look
like it has body ber of edges and doing a Subdivide Multi Fractal 
can quickly make the car’s body to a
 
  ROTATE EDGE (CW_CCW) ‘Crtl e’
  Basically refereed to by most other 3D programs as Flip Edges, but here in Blender it is 

kWise and CounterClockWise rotation. 

l 
and 

 
so 

 

Subdivide and Fractal are available 
 your Buttons WindowType- 

called Rotate Edge with the option of Cloc
  The Edge to be rotated is the usually the unseen one that splits a Quad, so first make a 
new Cube for yourself.  It has 6 quads that are actually 12 faces/tri’s with the Edge 
bisecting the quad hidden.  So to begin with you will need to unhide this edge by 
converting the Quad to Tri’s.  Put yourself in Edit Mode – Faces, keep in mind ‘Ctr
Tab’ allows changing sub-object select in 3D View Edit Mode.  Next pick a face 
using the Hot Box or Mesh> Faces> Convert to Triangles or ‘Ctrl t’ change the Quad
into two Tri’s.  You should now see an Edge running diagonal across the former Quad, 
back to Edge Mode.  Make sure nothing is selected using the ‘a’ key, and then select the
diagonal Edge.  Now Mesh> Edges> Rotate Edge CW (notice both CW and CCW plus a 
number of other actions show Ctrl E as their shortcut.  When Ctrl E is pressed in Edit 
Mode a list of Edge Specials actions comes, up so just one key combo can not carry out 
this action) or CCW will flip that Edge. 

 
 

in
Editing Panel- Mesh Tools. 
 


