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Helpful Keyboard Shortcuts 
 
Selecting Objects in EDIT MODE 
  ‘Shift’   when click selecting (sub)objects hold down the ‘Shift’ Key to select multiple 
objects. 
  ‘b’    Gives you border select tool for rectangular/marquee selection of an area.  Hit the 
‘b’ key and you’ll see dash vertical and horizontal lines extending out from your mouse’s 
cursor, now hold down your select mouse button and drag out a selection marquee area. 
  ‘Ctrl LMB/RMB’  by default ‘Ctrl LMB’ allows you to lasso select.  However if in 
preferences you’ve changed to LMB for selecting, then ‘Ctrl RMB’ can be used to lasso 
select (sub)objects. 
  ‘a’   Toggles all (sub)objects selected or no objects selected.  Useful to make sure 
you’ve nothing accidentally selected. 
  ‘Less’ and ‘More’ sub-object selection.    ‘Ctrl NumPad –‘and ‘Ctrl NumPad +’ with 
a sub-object (vertex, edge, face) selected use the plus (+) and minus (-) keys to increase 
and decrease connected similar sub-objects. 
(Blender shortcuts show capital letters, but it is not necessary to Caps Lock, small letters 
work). 
 
  Try it out in Blender. 
 
    Open Blender:   If no Window is set for 3D go to t
far left of a Header Menu Bar and press and hold on 
the Window Type Select icon.  A pull down (or up 
depending on if the menu bar is set to appear at the top 
or bottom of the Window) will appear and still holding 
down your mouse button move it over the list till ‘3D 
View’ is highlighted and release.    

he 

 
 
 
  Normally by default Blender starts off a new scene with a default Cube in the 3D View 
to begin modifying. 
 
A quick rundown on the 3D View follows. 
 
  This is a Default view where Blender has put in a Lamp, needed to see the object shaded 
in View and for Rendering shaded.  Also a camera for Rendering has been added by 
Blender, a render is from a camera’s viewpoint.  By Default there is a selected mesh 
cube, which you can see is outlined in pink to signify this to begin building from.  This is 
where the ‘a’ key comes in handy, so press ‘a’ to deselect all objects. 
 



 
 
  At the bottom is the Header Menu Bar, but remember this can be user set to appear at 
the top of the View or not at all to increase the workspace. 
  Far left is the Window Type, here set for 3d View, the View-Select-Object are hot 
areas where when clicked on bring up rollouts related to actions that can be used in this 
widow.  Click and hold to take a look at the actions.  The small arrow when clicked 
toggles these three items as shown are not. 
 
Mode Type when clicked brings up a list of modes available to this Window Type.  
With 3D View as Window Type theses modes deal with Object and Sub-Object 
manipulation choices.  For purpose of this paper we will be only interested in Edit Mode. 
 
Draw Mode deals with how the objects in a scene are represented or drawn in the scene.  
Click and try some of the other modes, however remember no textures or shaders have 
been added to the Cube so it stays default grey.  But the Cube will shaded based on the  
scene light’s position. 
 
Translate-Rotate-Scale is what type of action will be preformed on the selected 
object(s) or sub-object(s).  The hand icon toggles if you can view these items or not. 
 
Axis is for what axis to use when carrying out manipulations. 
  ‘Global’ – axis based on the 3D View’s world.   ‘Local’– axis from object. 
  ‘Normal’ – axis based on normal of selected sub-object. 
  ‘View’ – treats window an orthographic/flat view (Y up, X left/right, Z in/out). 
 



 
 
Depending on how you wish to manipulate and object in relationship to other objects, or 
sub-object components of an object to itself, may require you to choose a different axis to 
work with. 
 
 
EDIT MODE 
 
  Time to go into ‘Edit Mode’, click on your Cube to select it if not already highlighted; 
then click on the up/down arrows next to Mode Type, and from the list highlight and 
select ‘Edit Mode’ (shortcut is TAB key).  
 

  Upon doing so you will 
notice two changes to your 
Header Menu Bar. 
  To the left ‘Mesh’ has 
replaced ‘Object’ as a hot 
area, giving you new 
manipulation options. 
And at the right end a set of 4

new icons have appeared.  These icons allow you to select the type of sub-object 
component you wish to work on, Vertices – Edges – Faces, plus a fourth limiting 
selection to only visible sub-components also know as culling or clipping. 

 

  A darken icon denotes selection, so in the above image I have Vertices selected and 
clipping is turned on. 
 
First choose ‘Translate’ for the type of action you wish to carry out.  If you need to look 
at the image of the 3D View Window to locate the translate icon.  By default it is 
normally selected when you enter ‘Edit Mode’, remember the darken icon is the one 
selected. 
 
  You should now see the vertices of your Cube either as pink dots if not selected or 
yellow if they are.  If all your vertices are showing as yellow hit the ‘a’ key to deselect 
them, and they should all turn pink.   
 
  If you are not in a user perspective view, but a side –top –front view, rotate into a user 
view by holding down your MiddleMouseButton or (MMB).   Try to get a view similar 
to the 3D View Window above, where you get a ¾ view of the Cube. 
 
(IMPORTANT NOTE) 
  Rotating any flat view such as top-front-side puts you into ‘User’ view.  Even just a 
small movement where you might not notice the difference can affect your modeling.  
Because what might appear as straight up in a viewport, might actually now be slightly 
up and outwards or inwards. 



  One useful item to do is set your viewport to show their name, done under the ‘Users 
Preferences’ Window Type >Views&Controls; sub category  Display: >View Name. 
  However this only tells you’re the views name top-front-side-user, but not whether your 
in Perspective or Orthographic view. 
 
 
  Pick a vertex by clicking on it, the vertex should t
Yellow.  Hold down the ‘Shift’ key to click a few 
more.  In the picture to the left I have selected the two 
front top vertices and the lower right one.  For ease 
illustrating I’ve brighten the yellowed edges for 
effect.  On your cube you should see that an edge 
running between two selected vertices is yellow all 
the way across.  Between one selected and one non-
selected it is yellow only toward the end nearest the 
selected vertex. 
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  This is Blender helping you to visually see what 
edges will be affected by your manipulating those 
vertices. 
 

  Hit ‘a’ to deselect all and then 
try Edges as on the left, to do so 
click on the edges you want but 
notice if your click all the edges 
around a face it too highlights. 
 
  Lastly Faces (right image) and 
look close for a small back dot in 
the center of the face to click to 
choose that face (circled in 
orange). 

  Blender does this highlighting to help you get an easier feel for the area you are 
selecting, as on complex objects what is picked can get confusing at times. 
   
 
 

VERTEX MANIPULATION ACTIONS 
 
  Hit ‘a’ to deselect all items, then put yourself back in Vertex for Sub-Object type, and 
you should see your cube showing pink dots to indicate the vertices again. 
 
  Now we shall look at the Vertex manipulation tools available in Blender.  Since we are 
merely practicing with various tools, you may wish to expand/maximize your workspace 
if you are not already working in a single window space.  To do this go to the View 
Window you wish to enlarge and press ‘Ctrl UpArrow’ to maximize that Window.  
Pressing the keys again will return you to your multi window view. 



 
 
 
  There are two main ways to bring up your Vertex Actions, first using the ‘Mesh’ 
hotspot area on the Window Menu Bar.  Click here to see a list of Mesh Options while 
in Edit Mode, then highlight the ‘Vertices’ list item which will show a list of actions that 
can be taken on vertices.  For this paper we will deal with Merge-Rip-Split-Separate. 
 
  A second way is to use the Marker Menu sometimes also called a HotBox, from within 
the Window View itself.  To do this move your mouse to an area of the window where it 
is not close enough to and object to select it, then press and hold down either left or right 
mouse button (LMB, RMB).  After a few seconds a popup menu will appear under your 
mouse, then release and move your mouse to highlight ‘Edit’.  Off to the side another list 
showing Edit Options pops up, then slide your mouse over to highlight ‘Vertices’ and see 
a new pop up appear that lists Vertex Actions. 
 
  Either way works fine, and which way you prefer to use will depend more on how you 
like to model.  
 
Merge ‘Alt m’ - use this to merge two or more vertices together.  Select two vertices on 
your Cube either through a menu, Mesh> Vertices> Merge, or the keyboard short cut of 
‘Alt m’ execute the merge command.   
  A new pop up menu appears beneath your mouse cursor (caution moving the mouse off 
to the side ends the pop up) for what type of Merge you wish to do.   
   
  AT FIRST:  New single vertex is created at location of first vertex selected. 
 
  AT LAST:  New single vertex is created at location of last vertex selected. 
 

 
 
 
 
 
 
 



 
 
  AT CENTER:  Blender calculates what would be the center of the vertices selected, or  
      another way to think about it, the halve the distance between the vertices furthest  
      apart in each of the X, Y, and Z axis’. 
 
   
 
 
 
 
 
 
 
 
 
 
 
AT CURSOR:  New vertex placed at the location of the Marking Cursor, a caution  
    here to remember the Marking Cursor is in 3D space  Simply placing it where it looks 
    right from a 2D Window View, might not be where you really want it to be.  So check  
    from several views. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
COLLAPSE:  Like AT CENTER placing new vertex at center of selected vertices, but  
     vertices must share an edge. 
                                    
 
 
 
 
 
 
 



RIP ‘v’ - Creates another vertex from the one(s) selected, and splits edges used by that 
vertex.  Or ‘Rips’ them apart in Blender’s terms. 

 
 
SPLIT ‘y’ – Duplicates selected vertices and copies them, but the vertices are still part of 

e object. 

d by other 3D modeling programs. 
 
EXTRUDING VERTICES

th
 
SEPARATE ‘p’ – Duplicates selected vertices and copies them, but the vertices are a 
separate object.  Similar to ‘Detach’ command use

 
 

To Extrude a Vertex simple select it and go to 
Mesh >Extrude or ‘e’, and drag away the vertex 
which will create an edge connecting to the vertex 
first selected. 
 
 
 
 

If however more than one vertex is selected during Mesh >Extrude a pop up appears 

om the shared edge along with the vertices. 
s. 

  
asking ‘Only Edges’ and ‘Only Vertices’.  ‘Only Edges’ only those vertices that have an 
edge shared with other selected vertices will be extruded, and produce an extruded 
dge/face fre

  ‘Only Vertices’ ignores whether an edge is shared and just extrudes all selected vertice

 



SMOOTH ‘w, Alt1’ - Flattens the angles of selected faces.  So why in ‘Vertices’, it’s 
u also in the ‘Faces’ actions as well, but remember that 3 ‘Vertices’ make a face.  So if yo

select and area so that the vertices selected compose a number of connecting faces of 
sufficient angle Blender will try to do smoothing or flattening of the angles. 
 
(Note:  At times actions may seem to do nothing in Blender, but the program is smart 
enough to understand if you pick 2 vertices that share an edge,  some ‘Edge’ actions are 
available in ‘Vertices’.  Same with ‘Faces’ as well, so when working with sub-objects 
you are dealing with more than one component.  Two vertices can share an edge, a quad 
has 4 vertices and five edges, recall that a quad is two tri-faces so they share a non-shown 
inner edge.  So you can be in ‘Vertices’ Mode but still do a ‘Face’ Action. 
  But a listed ‘Action’ in the ‘Vertices’ Menu can pertain to an edge or face function,  and 
unless the correct Vertices are selected to make an edge or face the ‘Menu Action’ does 
not seem to work.  Once you’ve started using Blender for modeling you’ll begin to know 
what is needed for what ‘Action’.) 
  
Take your Cube with all ‘Vertices’ selected, try using the ‘a’ key, and then ‘Tool Box’ 

 

So we shall add a few more faces, but let’s Not go to Face Mode.  From the Note above 

 

  
or use the ‘Header Menu’ of Mesh >Vertices >Smooth or ‘w, Alt1’ to perform the 
‘Smooth’.  Your Cube looks to shrink a bit but not much else, this is because the smooth 
must work with the existing Geometry.  Your Cube just does not have enough faces to
work with. 
  
since all ‘Vertices’ are selected the ‘Edges’ that connect them are also considered 
selected by Blender.  So use the Tool Box, or Header Menu; or ‘w, 1’ to carry out the 
‘Edges’ Action of Sub-Divide. 
  When you get enough Sub-Divisions to your liking, run the ‘Smooth’ Action again, but 
take into account it works in small increments and you may need to apply the command 
several times. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



A TRICK FOR SMOOTH 
 
   Tired of going through the Menu or Tool Box, or hit multiple key combinations several 

mes? 
ry this way of doing it instead.

ti
T  

Setup a window for ‘Buttons Type’, then from the 
’ Icon locate and select ‘Editing’ (F9) and 

lick it.  Now look in the Sub-Menu Items for 
’.  This and Mesh Tools 1 are Editing 

ctions that can be carried out on Sub-Components 
f the Mesh (Vertices-Edges-Faces). 
Just click on ‘Smooth’ several times, to see how 
is button basically can handle all those other paths 
 one click. 

EMOVE DOUBLES: 
This would be in Max or Maya a Vertex Weld which operates on Selected Faces.  Say 
ou have 2 objects, or example 2 Planes, you arrange one so it edge over laps the other 

es.  Now by selecting all the overlapping vertices you can 
eld’ them together or in Blender terms ‘Remove Duplicate’ Vertices. 

er go to a top down view and Mesh >Add >Plane.   When you add a object 
guring if you’re addi

add another plane, again back into 
 meshes side by side with an edge 

ect >Join Objects, or ‘Ctrl j’.  
the overlapping Vertices 

’ll find they did not.  If you need to undo a Vertice 

rtices are back in place, grab all overlapping vertices, and since this is 
ifficult by try to click hit ‘b’ to evoke a box/marquee select or use ‘Ctrl RMB’ to lasso 

  Now carry out Mesh >Vertices >Remove Doubles, or ‘W, 6’. 

ere not close enough, as 

ld is set in the 

  
‘Panels
c
‘Mesh Tools
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o
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R
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also overlapping their vertic
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In Blend
Blender snaps into Edit mode, fi ng a Primitive you intend to start 
manipulating it.  So ‘Tab’ back to Object mode and 
‘Object’ Mode, and move one Plane placing the two
overlapping. 
  Next join the two Planes by selecting both and Obj
Switch to ‘Edit’ Mode – Vertices and check to see if 
automatically welded on join, and you
move made while checking use ‘Ctrl z’ to Undo. 
 
  Once the Ve
d
select the needed vertices.
 
  Finally check you vertices 
to see if they welded.  If not 
it maybe that your Vertices 
w
with Max or Maya when 
welding you have a 
distance threshold. 
 
  This thresho
Buttons Windows – 
Editing –Mesh Tools Area 



as well.   So look in the Mesh Tools area again like you did for Smooth, but now look for 
a box titled ‘Rem Doubl’.  Next to it is a numeric input box – ‘Limit:’.  Try adjusting this 

alue, the higher the value the further apart the Vertices being worked on can be and still 

ery small, and you set your Lim

t make it a habit to do and object weld on a mesh you make 
ing or rigging for animation.  To help remove unwelded vertices, 

ges that may have been accidentally created in modeling your 
tices Mode do a select all (‘a’), and set your Rem Doubl limit 
pefully this will get rid of the above listed problems. 

v
get welded or doubles removed. 
 
Caution:  If you are working on a very small object, for example if these Planes where 
v it high you could Remove or weld all Vertices in to one. 
 
Modeling Tip:  You migh
before beginning textur
and duplicate face and ed
object.  To do this in Ver
low the do a Remove.  Ho


